Функции рабочего листа для уравнения линейной регрессии

Пример 10. Определение параметров m и b с помощью функции НАКЛОН и ОТРЕЗОК:

1) Для нахождения m надо ввести в ячейку D2 формулу =НАКЛОН(B2:B7;A2:A7);

2) Для нахождения b надо ввести в ячейку E2 формулу =ОТРЕЗОК(B2:B7;A2:A7$);

3) Получила следующий результат:

Задание 3

1. Построение линейной модели по следующим данным:


2. Построение экспоненциальной модели:

Пример 11. Нахождение m и b с помощью точечного графика:

1) Выделила диапазон А2:В7, затем вставила точечную диаграмму (Вставка – Диаграммы – Точечная);

2) На появившуюся диаграмму щелкнула правой кнопкой мыши, в появившемся диалоговом окне выбрала команду Добавить линию тренда;

3) В диалоговом окне Линия тренда выбрала параметр – Линейная; установила флажки на пунктах Показать уравнение на диаграмме и Поместить на диаграмму величину достоверности аппроксимации;

4) Нашла теоретические значения у введя в ячейку С2 формулу =$D$2*A2+$E$2 и растянув на диапазон С2:С7:

Тема 3. Решение нелинейных уравнений а Excel

3.1. Нахождение корней уравнения

Пример 12. Пример нахождения всех корней уравнения

1) Протабулировала полином на отрезке[1;-1] шагом 0,2 в столбце А;

2) В ячейку В2 ввел следующую формулу =A2^3-0,01*LOG(139;139)*A2^2-0,7044*A2+0,139104;

3) По получившимся результатам построила график;

4) В ячейки С2:С4 ввела приближенные значения в ячейку D2 ввела формулу =C2^3-0,01*LOG(139;139)*C2^2-0,7044*C2+0,139104 протащила на ячейки D3, D4;

Задание 4.

Решение:

1) Протабулировала полином на отрезке[1;-1] шагом 0,2 в столбце А;

2) В ячейку В2 ввела следующую формулу =A2^3-2,92*A2^2+1,4355*A2+0,791136+7/1000;

3) По получившимся результатам построила график;

4) Получившийся график имеет одно пересечение с осью Ох = -0,4 и в ячейку С2 ввела это значение;

5) В ячейку D2 ввела формулу =C2^3-2,92*C2^2+1,4355*C2+0,791136+7/1000;

3.2. Нахождение корней уравнения методом деления отрезка пополам

Пример 13. Нахождение корня уравнения с точностью до 0,001 методом деления отрезка пополам.

1) В ячейку В1 ввела погрешность нахождения корня 0,001;

2) За первоначальный отрезок локализации приняла отрезок [0;2];

3) В ячейки C3, D3, E3, A4, B4, F4 ввела необходимые формулы Соответственно

=(A3+B3)/2

=(A3^2-2)*(C3-2)

=C3^2-2

=ЕСЛИ(D3<=0;A3;C3)

=ЕСЛИ(D3<=0;C3;B3)

=ЕСЛИ(B3-A3<$B$1;"Корень найден и равен" &ТЕКСТ(C3;"0?0000");"")

4) Получила решение:

Задание 5. Решить уравнение :

1) В ячейку В1 ввела погрешность нахождения корня 0,001;

2) За первоначальный отрезок локализации приняла отрезок [0;2];

3) В ячейки C3, D3, E3, A4, B4, F4 ввела необходимые формулы:

=(A3+B3)/2

=(A3^4-7)*(C3^4-7)

=C3^4-7

=ЕСЛИ(D3<=0;A3;C3)

=ЕСЛИ(D3<=0;C3;B3)

=ЕСЛИ(B3-A3<$B$1;"Корень найден и равен" &ТЕКСТ(C3;"0?0000");"")

4) Получила решение: 0,0002

Список литературы:

1. Тихомиров, А.Н.

MICROSOFT OFFICE 2007, Все программы пакета: WORD, EXCEL, ACCESS,POWERPOINT, PUBLISHER, OULOOK, ONENOTE, INFOPATH, GROOVE[текст]: Самоучитель / А.Н. Тихомиров , А.К. Прокди, П.В. Колосков, И.А. Клеандрова и др..- Владимир : Наука и Техника, 2008. – 608 с.: ил.+ цв. вклейки.ISBN5-222-01259-X

2. Мартин, М.З.

Excel для Windows 95/97[текст]: М.З. Мартин - Москва: АВЕ. - 1996.- 248с.- ISBN966-7104-40-0

3. Комягин, В.Б.

Excel 7.0 в примерах [текст]: А.О. Коцюбинский, В.Б. Комягин.- Ростов-на-Дону: Нолидж, 1996.- 275с.-ISBN966-635-542-6


3900479261669562.html
3900573965054690.html
    PR.RU™